Moodle 2.8.7+ Update for Fall 2015

Print Friendly

Moodle-icon

Emily Carr University’s Moodle course mangement system will update to version 2.8.7+ for the Fall 2015 semester.

Faculty can review the Moodle_2.8.7_release_notes  or view the video links below to see the feature changes.

For a detailed description of each of these new features, including links to video tutorials, please see the official Moodle 2.8 New Features guide.

note
Recommended minimum browser: recent Google Chrome, recent Mozilla Firefox, Safari 6, Internet Explorer 9 (IE 10 required for drag and drop of files from outside the browser into Moodle).

  • IE8 and Safari 5 are no longer fully supported. They may still work but they are not tested regularly and there might be some problems. Like most of the world’s Web sites and browser producers, we encourage you to keep your browsers current to improve security and functionality while saving us valuable time. (For example see what Google is doing.)
  • IE6 and IE7 are not recommended for Moodle 2.8 at all. You will encounter difficulties trying to use those old browsers in today’s Internet.

Online Tutorials
Faculty can take the Moodle 2.8 Essential Training Course on Lynda.com at  http://www.lynda.com/Moodle-tutorials/Moodle-2.8-Essential-Training/370012-2.html or the Moodle Advanced Techniques course at http://www.lynda.com/Moodle-tutorials/Moodle-Advanced-Techniques/370199-2.html Please note: Emily Carr faculty should first go to the ECU Lynda.com login page at http://www.ecuad.ca/library/lynda

Getting Started
Come to the Teaching and Learning Centre in room 201 in the north building on the Emily Carr campus for a getting started consultation or request one by sending an email to tlc@ecuad.ca. Individual and group workshops can be scheduled or will be announced on this site and through email.

 

Teaching and Learning Centre © 2017 All Rights Reserved

Copyright of Emily Carr University